Details

    • Include in Release Notes:
      No

      Description

      I am trying to setup a DC/OS OSS cluster with latest version and terraform script but I am unable to use custom Auth0 provider for authentication.

      config on terraform

      ```
      dcos_config=<<EOF
      rexray_config_preset: aws
      oauth_enabled: 'true'
      oauth_issuer_url: https://mydomain.auth0.com
      oauth_client_id: myClientID
      oauth_auth_redirector: https://mydomain.auth0.com
      oauth_auth_host: https://mydomain.auth0.com
      EOF
      ```
      If I install the cluster with these details, I am unable to create first user.
      It gives the following error on console.
      https://imgur.com/e4JXtwA
      image of error
      Related:

      https://github.com/Rohithzr/dcos-docs/blob/dcos-632/1.9/administration/id-and-access-mgt/configure-your-security.md
      https://github.com/dcos/dcos-docs/pull/885

      https://jira.mesosphere.com/browse/DCOS_OSS-632

       

       
       
       
       

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                rohithzr Rohit Hazra
                Team:
                Mesosphere
                Watchers:
                Dominik Dary, Jan-Philip Gehrcke (Inactive), Jonathan Giddy, raghu999, Rohit Hazra
              • Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated: