Details

    • Sprint:
      Studio 3: RI-21 61, Studio 3: RI-22 62
    • Story Points:
      1
    • Include in Release Notes:
      Yes

      Description

      This was reported in the DC/OS Community Slack:

      https://dcos-community.slack.com/archives/C679W902Y/p1572611301013200

      I found a problem when I upgraded to dcos 2.0.0 from 1.13.5 for few servers (4 among 11) that didn't have sse4_2 processor instructions. The upgrade went well echo $? was 0 but the adminrouter-agent service was not restarting. the new version of libluajit 5.1 use sse4_2 instruction and make the adminrouter-agent service crash on startup. So I had to downgrade for these servers only the package adminrouter-agent modifying the /etc/systemd/system/dcos.target.wants/dcos-adminrouter-agent.service (with an old version of the package) and had to add symlinks to libssl/libcrypto 1.0.0 in /opt/mesosphere/lib pointing to an old openssl package in /opt/mesosphere/packages.

      In short, it looks like users that are on very old generations of CPU that do not support SSE 4.2 (pre-Nehalem in Intel's case) will be unable to upgrade to more recent version of DC/OS.

        Attachments

          Activity

            People

            • Assignee:
              jonathangiddy Jonathan Giddy
              Reporter:
              nickjones Nick Jones (Inactive)
              Team:
              Mesosphere
              Watchers:
              Cassandra Oxford, Jonathan Giddy, Mergebot, mimmus, Nick Jones (Inactive)
            • Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: